Downloads

Electrum Wallet for Coldcard

Please visit the main Electrum site to get version 3.2.3 or later, which now supports Coldcard out of the box. To use Coldcard in a multisig wallet with Electrum, you will need version 4.0.0 or higher.

We strongly recommend you personally verify the PGP signatures that are shared on that page. Electrum is signed by Thomas Voegtlin's key 0x3731165361672a66. It's important to trust the source of your desktop wallet software.

Coldcard Firmware

Please visit this page for the latest firmware for the Coldcard itself, and how to upgrade.

Old Firmware Files

For reference purposes, and to support older hardware, we publish these historical firmware releases.